๐ŸŽ‰ Happy 19th Birthday to Danbooru! ๐ŸŽ‰
Danbooru

Getting failbooru tag searches

Posted under General

ROMaster2 said:
The first one worked for me, the second one timed out each time I tried.

Same here.

As long as we're talking about failboorus I get hit with them on these:

width:>=3200 -absurdres
height:>=2400 -absurdres
width:>=1600 -highres
height:>=1200 -highres
width:<=500 height:<=500 -lowres

whenever they have less than a page of results. Not that big of deal I suppose, but it just bugs me that there are perpetually a few dozen posts I'm not able to get at.

EDIT: Right after I posted this I thought to use black listing to root out those last few and it worked fine. I can't believe it took me 2 months to think of this. The searches are still borked for me, but it's more or less not a problem for my purposes anymore.

Updated

If this is the case, maybe it would be a good idea to move some of the search filtering to the client side officially. We could set the system to do all base tag stuff server side, then winnow things based on metatag and tag negations in the client, much the way the blacklist works now.

I get the often coming and very annoying failbooru when I do the following:

- Doing a tag search
- Tag editing
- Uploading via bookmarklet or DanbooruUp
- Clicking onto a post to add it to my fave
- Refreshing a page.

#2 and #3 is the more common times I encounter Failbooru.

Updated

I'm getting random failboorus at least once a day through normal browsing and tag edits. I also get a lot of failboorus trying to access JXH's account page. Its only his page, so I don't know what the issue is.

Its the same as Mr_GT is reporting.

Action_Kamen said:
Its been happening a lot, for a long time now. Especially when I'm searching for specific touhou characters in my favorites. For example fav:Action_Kamen reiuji_utsuho, fav:Action_Kamen letty_whiterock and a couple other searches.

Any ideas on what I can do to fix this?

I mentioned it before (forum #55728), if you add order:score or order:favcount to the query, it works for some odd reason. Seems only appy to favorite searches though.

eidolon said:
I mentioned it before (forum #55728), if you add order:score or order:favcount to the query, it works for some odd reason. Seems only appy to favorite searches though.

Probably because then it's not doing the default order-by-favorited-date. Actually, looking at the DB schema just now, the created_at column of the favorites table doesn't appear to have an index.

albert said:
There's no way these searches will ever be fast, especially the last three. You're basically searching for posts without a tag. This means checking every single post. It just can't be indexed well.

I filed a ticket about this in the Trac about a year and a half ago, actually. Why are we still doing the absurdres and the like manually rather than adding it automatically on upload?

1